THE PASTE SPECIAL FUNCTION

Excel allows you to copy and paste specific information from one cell to another through the Paste Special function. You can choose to copy and paste only a formula, a value, or formatting characteristics.

Defining the Options of the Paste Special Dialog

The following table describes the differences amongst the various paste options.

<table>
<thead>
<tr>
<th>Paste Special Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Pastes all cell contents and formatting of the copied data.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Only the formula of the original cell is pasted. The rules on relative and absolute references will apply.</td>
</tr>
<tr>
<td>Values</td>
<td>Only the value of the original cell is pasted. For example, if the original cell has a formula of =4+5, the copied cell will contain the value 9 and not the formula.</td>
</tr>
<tr>
<td>Formats</td>
<td>Only the format of the original cell is pasted. For example, if the original cell has red font, bold, and green color background, only those aspects of the cell will be pasted onto the copied cell.</td>
</tr>
<tr>
<td>Comments</td>
<td>Only a cell’s comment is pasted.</td>
</tr>
<tr>
<td>Validation</td>
<td>Only data validation rules are pasted. Data validation rules are restrictions that you create for data entry. For example, you might want your cells only to accept whole numbers, as opposed to decimals.</td>
</tr>
<tr>
<td>All Using Source Theme</td>
<td>Pastes all cell contents and the document theme.</td>
</tr>
<tr>
<td>All Except Borders</td>
<td>Everything will be pasted from the original cell except for any border formatting.</td>
</tr>
<tr>
<td>Column Widths</td>
<td>The width of one column will be applied to another column.</td>
</tr>
<tr>
<td>Formulas and Number Formats</td>
<td>The formula and the formatting of the original cell is pasted. The rules on relative and absolute references will apply.</td>
</tr>
<tr>
<td>Values and Number Formats</td>
<td>Only the value and the formatting of the original cell is pasted.</td>
</tr>
<tr>
<td>Operation</td>
<td>Specifies which mathematical operation, if any, you want to applied to the copied data.</td>
</tr>
<tr>
<td>Skip Blanks</td>
<td>Avoids replacing values in your paste area when blank cells occur in the copy area.</td>
</tr>
<tr>
<td>Transpose</td>
<td>Changes the columns of copied data to rows, and vice versa.</td>
</tr>
<tr>
<td>Paste Link</td>
<td>Links the pasted data on the active worksheet to the copied data, so that it updates automatically.</td>
</tr>
</tbody>
</table>
Using the Paste Special Function

1. Select the cell(s) that contains the information you want to copy.
2. Simultaneously press the Ctrl and C keys on the keyboard to copy the information.
3. Animated lines will surround the cell(s).
4. Go to the Home tab.
5. Click on the bottom half of the Paste icon.

6. A submenu will appear.
7. Choose the option Paste Special.
8. The Paste Special dialog will appear.

9. Select the desired option.
10. Click on the OK button.
11. The copied information will be pasted into the new cell(s) per your command.

**Note 1:** After using the Values option of the Paste Special Function, any subsequent changes that you make to the original cell will not be conveyed to the copied cell(s).

**Note 2:** The Transpose option located in the lower right-hand corner of the Paste Special dialog transposes that which you are copying and pasting. In other words, if the copied information is contained in two rows across the spreadsheet, the pasted information will appear in two columns going down the sheet.
ORGANIZING DATA

Multiple-Level Sorting
Sorting is used to organize the sets of data in your worksheet alphabetically, numerically, or chronologically. When you sort a set of data, Excel arranges the rows according to the content of one or more columns, depending upon whether you do a single-level or multiple-level sort.

Before sorting, Excel will compare the top row of your data set for formatting differences. If the top row is formatted differently from the subsequent rows, then Excel will identify the top row as data headers and will exclude it from the sort.

1. Open the spreadsheet that contains the data you wish to sort.
2. Click once within the data set.
3. Go to the Home tab.
4. Click on the Sort and Filter icon.
5. Select the Custom Sort option from the submenu that appears.
6. The Sort dialog will appear.
7. Select a Sort by column.
8. Select a Sort on choice.
9. Select an Order.
10. Click on the Add Level button for another tier and repeat steps 7 through 9.
11. Once you have all of your tiers, click on the OK button.
12. Your data will be sorted accordingly.

Note: For sorting days of the weeks or months in chronological order, you will need to click on the Custom List option, accessed by clicking on the downward pointing arrow to the right of the Order column. The Custom Lists dialog will appear, providing you with more sorting options.
Subtotaling Sorted Data Sets
Automatic subtotals help you summarize the sorted data in your worksheet. When you insert subtotals, Excel creates an outline of your data that enables you to show or hide certain levels. Grand-total values are derived from the data set, not from the subtotal rows.

1. Open the spreadsheet that contains the data you wish to sort.
2. Click once within the data set.
3. Perform your desired sort.
4. Go to the Data tab.
5. Click on the Subtotal icon.
6. The Subtotal dialog will appear.

7. Choose the desired column name from the At Each Change In dropdown list.
8. Choose the desired function from the Use Function dropdown list.
9. Enable the desired column on which to perform the function in the Add Subtotal To field.
10. Click on the OK button.
11. Your data will now be presented in an outline format, so that you can display and hide the detail rows for each subtotal.

12. Click on the 1, 2 or 3 under the Name Box to view the different data outlines.

Note: To remove data subtotals from your worksheet, display all of your data (in this case, by clicking on the 3 under the Name Box), select a cell in your data list, display the Subtotal dialog, and click on the Remove All button.

Note 2: Do not use blank rows or dashed lines to separate your column labels from the data list below, as blank rows and/or dashed lines will also be sorted.

Note 3: When you use formulas in your data, Excel sorts according to the values displayed.
Filtering Data
When you filter a data set, you display only the sets of data that meet your criteria. When you use the filter command, dropdown arrows are displayed to the right of each column label in your data set. Clicking on a dropdown arrow displays a list of all the unique entries in that column.

1. Open the spreadsheet that contains the data you wish to filter.
2. Click once within the data set.
3. Go to the Data tab.
4. Click on the Filter icon.
5. Dropdown arrows will now be displayed to the right of each column label.

6. To filter by a column header, click on its dropdown arrow.
7. A menu will appear, featuring sorting and filtering options.

8. Choose the criterion for your filter in the Text Filters section and click on the OK button.
9. Only the data that meets your filter criterion will be visible.
10. You can filter by as many columns as you like.
11. The example below has been filtered by Division, then Department, then Hourly Rate.

Note: To remove a specific filter, display the column’s filtering menu and choose the Select All option. All of the data within that column will be visible.

Note 2: To remove all filters, click on the Filter icon in the Data tab. All dropdown arrows will disappear.
CONDITIONAL FORMATTING

Conditional formatting is a tool that allows you to apply formats to a range of cells, in which the cell's formatting changes depending on the value of the cell. To apply a preset conditional formatting rule, follow the instructions below.

Applying a Conditional Formatting Rule

1. Open the spreadsheet that contains the data you wish to format.
2. Click once within the data set.
3. Perform your desired sort.
4. Select the cells to apply the conditional formatting.
5. Go to the Home tab.
6. Click on the Conditional Formatting icon.
7. Hold your cursor over the desired option from the sub menu.
8. Choose the desired formatting from the gallery that appears.
9. The conditional formatting will be applied.

Note: Conditional formatting only works on cells containing numbers or dates. It is best used to highlight increases or decreases in value.
Modifying a Conditional Formatting Rule
1. Open the spreadsheet that contains the conditional formatting.
2. Select the cells to which you have applied the conditional formatting.
3. Go to the Home tab.
4. Click on the Conditional Formatting icon.
5. Select the Manage Rules option from the sub menu.
6. The Conditional Formatting Rules Manager dialog will open.
7. Click on the Edit Rule button.

8. The Edit Formatting Rule dialog will appear.

9. Make your changes and click on the OK button.
10. You will return to the Conditional Formatting Rules Manager dialog.
11. Click on its OK button.
12. Your new rules will go into effect immediately.

Note: To remove conditional formatting, click on the Conditional Formatting icon and choose the option Clear Rules. You can remove the formatting from the selected cells or the entire worksheet.
CHARTS

Creating a Basic Chart
Charts graphically represent data sets, which can make the information easier to understand. The creation of basic charts is incredibly easy in Excel 2007. To create a chart, follow the directions below.

1. Open the spreadsheet that contains the data you wish to chart.
2. Select the data you want to chart.
3. Go to the Insert tab.
4. In the Charts section, click on the icon that displays your desired chart type.

5. Various sub-types of the particular chart type will be displayed.

6. Click on the icon that displays your desired chart sub-type.
7. That chart type, graphically representing your data, will be inserted into the same worksheet as the data.

Note: Never include totals in the selected chart data, as the charts calculate the totals themselves.
Modifying Charts
After creating a basic chart, you can modify its appearance, the data, and where it appears within your workbook.

Changing Chart Types
1. Click once on your chart to select it.
3. Go to the Chart Tools - Design tab.
4. Click on the Change Chart Type icon.
6. The **Change Chart Type** dialog will appear.

![Change Chart Type Dialog]

7. Select the desired chart type from the left-hand side of the dialog and then the desired sub-type from the right-hand side of the dialog.

8. Click on the **OK** button.

9. Your chart type change will go into effect immediately.

![Spreadsheet and Chart Example]
Changing a Chart’s Data

1. Click once on your chart to select it.
3. Go to the Chart Tools - Design tab.
4. Click on the Select Data icon.
6. The **Select Data Source** dialog will appear and animated lines will surround the original data.

7. Use your mouse to select the new data that you want to chart.
8. Click on the **OK** button.
9. Your chart will update to reflect the new data chosen.
Switching a Chart’s Data over the X and Y Axes

1. Click once on your chart to select it.
3. Go to the Chart Tools - Design tab.
4. Click on the Switch Row/Column icon.

5. The data being charted will switch. That is, the data being charted on the X axis will move to the Y axis and vice versa.
Changing a Chart’s Location
1. Click once on your chart to select it.
3. Go to the Chart Tools - Design tab.
4. Click on the Move Chart Location icon.
5. The Move Chart dialog will appear.
6. Determine whether you want the chart as an object embedded in your current worksheet or if you want your chart on a new sheet within your workbook.
7. Click on the OK button.
8. Your chart will appear in the desired space.

Note: You can name your new worksheet before placing your chart on it by typing the desired name in the New Sheet field before clicking on the OK button.
Formatting a Chart’s Data Series

1. Click once on your chart to select it.
3. Go to the Chart Tools - Design tab.
4. Click on the More icon of the Chart Styles section.

5. A selection of chart styles will appear.
6. Click on the icon that represents the style that you like best.
7. The formatting change will go into effect immediately.
Adding Chart Titles, Legends, Data Labels and Trendlines

1. Click once on your chart to select it.
3. Go to the Chart Tools - Layout tab.

4. To add a title to your chart, click on the Chart Title icon.
5. To change the position of your chart’s legend, click on the Legend icon.
6. To add data labels to your chart, click on the Data Labels icon.
7. To add a trendline, click on the Trendline icon.

Note: You can also change the color of your data series from within the Chart Tools - Layout tab.

- Click once on a single data series to select the entire series (see Image 1 below).
- Click on the Format Selection icon, located on the left-hand side of the Chart Tools - Layout tab.
- The Format Data Series dialog will appear.

- Click on the Fill category, choose the Solid Fill option, and then select the color of your choice via the Color icon.
- If you do not like your new formatting, click on the Reset to Match Style icon (located below the Format Selection icon) to return to the original formatting.

Image 1: a chart with all of the blue data series selected: note the fill handles surrounding all of the blue columns.